<!DOCTYPE html>
<html lang="en">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1.0" >
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<title>It&#8217;s Been a Tough Rookie Season For LA Kings LW Prospect Mikey Eyssimont</title>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Oswald:r:latin,latin-ext","Noto+Serif:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://s0.wp.com/wp-content/plugins/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">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</style>
<meta name="google-site-verification" content="s2OQTLIIz611UNaPusGAcInCEvq0Mwt7ckmy3AIjKu4" />
<meta name="msvalidate.01" content="CF85DF9FDAF1578BDE0F23C84DE368AB" />
<meta name="p:domain_verify" content="86919fd53d1954bc87eccd28f701a578" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=frozenroyalty.net&amp;id=4307834&amp;t=1551525345&amp;back=https%3A%2F%2Ffrozenroyalty.net%2F2019%2F02%2F28%2Feyssimont-0219%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//frozenroyalty.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.pubmine.com' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//static.criteo.net' />
<link rel='dns-prefetch' href='//ib.adnxs.com' />
<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
<link rel='dns-prefetch' href='//bidder.criteo.com' />
<link rel='dns-prefetch' href='//cas.criteo.com' />
<link rel='dns-prefetch' href='//gum.criteo.com' />
<link rel='dns-prefetch' href='//ads.pubmatic.com' />
<link rel='dns-prefetch' href='//gads.pubmatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//ad.doubleclick.net' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.g.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.swid.switchadhub.com' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="https://frozenroyalty.net/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="https://frozenroyalty.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; It&#8217;s Been a Tough Rookie Season For LA Kings LW Prospect Mikey&nbsp;Eyssimont Comments Feed" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1550249335h&ver=5.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJx9kF1uAjEMhC/U4IIKFQ+oZ8mPtYR1EitOWHH7mm1BK1bixYpH33jswMTGl9wwN0jdMPUhZgGKIwpcsLH1o5m7jRf5gAXuqAxPw1RqsEFgoOIsrdjF6IpkGwbDRdpL97TF7KkH3UAFCFHmsHkRV229gbQb4SbF/C7Il4qqJ7btTiQM0SJhUuydLfHh4bo/z/oB69sX/MRKG+e4oojRmmJPpp01aO37k4G7A2dlxHqNRGh2/xcp/pNO2/3+c3v8/jrsLr9xLprM?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='baskerville-2-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%2C700%7CRoboto%3A400%2C400italic%2C700%2C700italic%2C300%7CPacifico%3A400&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJyNjFFOAzEMBS9EsFpK+ao4izd4U7NOHG28BG6PaamgqlTt3zzZM9BriFqMioEdKVODugwwYJto/mARClsY/QE7Nc104vA7HmNrD7CmwCVCsy/nXqPmGzEvocqSuDTo/JbIGtDiV52YgmAHo1wFzeOnzJrAiJEGLwThyeFzvelsmGbMf7RGaxoZJbC/XI+zzFDUzscL3Ksm0iAa0VjL1QijIM/31JkG0eSYwL/+zR/pNR82z9uX/dNus9u/fwO43cC3?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/_static/??-eJx9i0EKQjEMBS9kDdVfXIlnyS+1jaRJafLx+uJCRBRXbx7MwH2ErOJFHPoWBm+VxACzk8qK8037bLaD3/pQ83BlpAnWcJLU1/6rTDMhB9aqn+cr8lZ6MWgLVNYV+Slc+jmmQzrFtMTj7QHFQEmu?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFj+EKwjAMhF/Iroxt6B/xWeoWS2qb1iZ16NPbgf5Qh0IgHPmOu+g5KaTRlwlYuzqXAvn2XI3jjf4FqIA2G4EmIL3gMZIAycKmyBKA2VhYuYZ4RA+qMOQKkNSYU1zh3ishXRHmv5gDSWY8qwyM96/0UFTyxSKxzuDrA5Naun6o6jqEfTsMbbfddX3vHjBBcHQ='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://frozenroyalty.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='A Longer Look At LA Kings D Prospect Matt&nbsp;Roy' href='https://frozenroyalty.net/2019/02/18/matt-roy/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/" />
<link rel='shortlink' href='https://wp.me/pi4Fc-ePl' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Ffrozenroyalty.net%2F2019%2F02%2F28%2Feyssimont-0219%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Ffrozenroyalty.net%2F2019%2F02%2F28%2Feyssimont-0219%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="It&#8217;s Been a Tough Rookie Season For LA Kings LW Prospect Mikey Eyssimont" />
<meta property="og:url" content="https://frozenroyalty.net/2019/02/28/eyssimont-0219/" />
<meta property="og:description" content="EL SEGUNDO, CA &mdash; Like it or not, with the Los Angeles Kings having traded veteran defenseman Jake Muzzin, along with veteran forward Nate Thompson and then, defenseman Oscar Fantenberg, in re…" />
<meta property="article:published_time" content="2019-02-28T23:48:58+00:00" />
<meta property="article:modified_time" content="2019-03-01T00:02:43+00:00" />
<meta property="og:image" content="https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg" />
<meta property="og:image:width" content="736" />
<meta property="og:image:height" content="512" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@frozenroyalty" />
<meta name="twitter:site" content="@frozenroyalty" />
<meta name="twitter:text:title" content="It&#8217;s Been a Tough Rookie Season For LA Kings LW Prospect Mikey&nbsp;Eyssimont" />
<meta name="twitter:image" content="https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://frozenroyalty.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://frozenroyalty.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://frozenroyalty.net/osd.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="theme-color" content="#cccccc" />
<link rel="pingback" href="https://frozenroyalty.net/xmlrpc.php"><meta name="application-name" content="WordPress.com" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://frozenroyalty.net/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="EL SEGUNDO, CA &mdash; Like it or not, with the Los Angeles Kings having traded veteran defenseman Jake Muzzin, along with veteran forward Nate Thompson and then, defenseman Oscar Fantenberg, in recent weeks, the reality is that the Kings are officially in a rebuilding mode. For the uninitiated, that means at least a few years&hellip;" />
	<style type="text/css" id="baskerville-header-css">
			.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
		</style>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #cccccc; }
</style>
			<script type="text/javascript">
		function __ATA_CC() {var v = document.cookie.match('(^|;) ?personalized-ads-consent=([^;]*)(;|$)');return v ? 1 : 0;}
		var __ATA_PP = { pt: 1, ht: 1, tn: 'baskerville-2', amp: false, siteid: 4307834, consent: __ATA_CC() };
		var __ATA = __ATA || {};
		__ATA.cmd = __ATA.cmd || [];
		__ATA.criteo = __ATA.criteo || {};
		__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>
		<script type="text/javascript" src="//s.pubmine.com/head.js" async></script><link rel="amphtml" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
<style type="text/css" id="custom-colors-css">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</style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=i4Fc&#038;cscache=6&#038;csrev=92" />
		</head>

<body class="post-template-default single single-post postid-56999 single-format-standard custom-background wp-custom-logo mp6 customizer-styles-applied group-blog no-featured-image highlander-enabled highlander-light custom-colors">

	<a class="screen-reader-text skip-link" href="#content">Skip to content</a>

	<header class="header section small-padding bg-dark bg-image" style="background-image: url(https://frozenroyalty.files.wordpress.com/2018/06/cropped-img_38321.jpg);" role="banner">

		<a href="https://frozenroyalty.net/" rel="home">
			<div class="cover"></div>
		</a>

		<a href="#search-container" class="screen-reader-text search-toggle">Search</a>
		<div class="header-search-block bg-graphite hidden" id="search-container">
			<form role="search" method="get" class="search-form" action="https://frozenroyalty.net/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>		</div> <!-- /header-search-block -->

		<div class="header-inner section-inner">

			<a href="https://frozenroyalty.net/" class="custom-logo-link" rel="home" itemprop="url"><img width="736" height="370" src="https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png" class="custom-logo" alt="" itemprop="logo" srcset="https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png?w=736&amp;h=370 736w, https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png?w=150&amp;h=75 150w, https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png?w=300&amp;h=151 300w, https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png?w=768&amp;h=386 768w, https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png 1017w" sizes="(max-width: 736px) 100vw, 736px" data-attachment-id="55822" data-permalink="https://frozenroyalty.net/cropped-kings_frozen-png-2/" data-orig-file="https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png" data-orig-size="1017,511" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-kings_frozen.png" data-image-description="&lt;p&gt;https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png&lt;/p&gt;
" data-medium-file="https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png?w=300" data-large-file="https://frozenroyalty.files.wordpress.com/2018/06/cropped-kings_frozen.png?w=736" /></a>
							<p class="site-title"><a href="https://frozenroyalty.net/" rel="home"></a></p>
			
			
		</div> <!-- /header-inner -->
	</header> <!-- /header -->

	<div class="navigation section no-padding bg-dark">
		<nav id="site-navigation" class="navigation-inner section-inner clear" role="navigation">
			<button class="nav-toggle fleft" aria-controls="primary-menu" aria-expanded="false">Menu</button>
			<div class="main-navigation">
				<ul id="primary-menu" class="menu"><li id="menu-item-55806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55806"><a>About Us</a>
<ul class="sub-menu">
	<li id="menu-item-13310" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13310"><a href="https://frozenroyalty.net/comment-policy/">Comment Policy</a></li>
	<li id="menu-item-39577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39577"><a href="https://frozenroyalty.net/aboutcontact/">Contact Us</a></li>
	<li id="menu-item-55805" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55805"><a href="https://frozenroyalty.net/staff/">Staff</a></li>
</ul>
</li>
<li id="menu-item-41231" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41231"><a href="https://frozenroyalty.net/attending-los-angeles-kings-practice-sessions/">Attending Kings Practices</a></li>
<li id="menu-item-19441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19441"><a href="https://frozenroyalty.net/copyright-licensing/">Copyright/Licensing</a></li>
<li id="menu-item-55717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55717"><a>Follow/Social Media</a>
<ul class="sub-menu">
	<li id="menu-item-55807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55807"><a href="https://www.facebook.com/FrozenRoyalty">Facebook</a></li>
	<li id="menu-item-55720" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55720"><a href="https://www.instagram.com/frozenroyaltynhl">Instagram</a></li>
	<li id="menu-item-55718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55718"><a href="https://twitter.com/frozenroyalty">Twitter</a></li>
	<li id="menu-item-55731" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55731"><a href="https://pinterest.com/frozenroyalty">Pinterest</a></li>
	<li id="menu-item-55721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55721"><a href="https://www.youtube.com/frozenroyaltynhl">YouTube</a></li>
</ul>
</li>
<li id="menu-item-55815" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55815"><a>Categories</a>
<ul class="sub-menu">
	<li id="menu-item-55808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55808"><a href="https://frozenroyalty.net/category/audiovideo/">Audio/Video</a></li>
	<li id="menu-item-55809" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55809"><a href="https://frozenroyalty.net/category/exclusives/">Exclusives</a></li>
	<li id="menu-item-55810" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55810"><a href="https://frozenroyalty.net/category/history/">History</a></li>
	<li id="menu-item-55811" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55811"><a href="https://frozenroyalty.net/category/news/">News</a></li>
	<li id="menu-item-55812" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55812"><a href="https://frozenroyalty.net/category/post-game/">Post-Game</a></li>
	<li id="menu-item-55813" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55813"><a href="https://frozenroyalty.net/category/prospects-2/">Prospects</a></li>
	<li id="menu-item-55814" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55814"><a href="https://frozenroyalty.net/category/stanley-cup-playoffs/">Stanley Cup Playoffs</a></li>
</ul>
</li>
</ul>			</div>

			<a class="search-toggle search-icon fright" href="#">Open Search</a>
		</nav> <!-- /navigation-inner -->
	</div> <!-- /navigation -->

<div class="wrapper section medium-padding">
	<main class="section-inner clear" role="main">

				<div class="content clear fleft" id="content">

			

	<article id="post-56999" class="post-56999 post type-post status-publish format-standard has-post-thumbnail hentry category-exclusives category-news category-prospects-2 tag-ahl tag-american-hockey-league tag-mikey-eyssimont tag-ontario-reigh clear">

		<header class="post-header"><h1 class="post-title entry-title"><a href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/" rel="bookmark">It&#8217;s Been a Tough Rookie Season For LA Kings LW Prospect Mikey&nbsp;Eyssimont</a></h1></header>			<div class="featured-media">
				<img width="805" height="560" src="https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg?w=805" class="attachment-baskerville-2-post-image size-baskerville-2-post-image wp-post-image" alt="" srcset="https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg 805w, https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg?w=150 150w, https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg?w=300 300w, https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg?w=768 768w" sizes="(max-width: 805px) 100vw, 805px" data-attachment-id="57002" data-permalink="https://frozenroyalty.net/dsc_2715-2/" data-orig-file="https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg" data-orig-size="805,560" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;11&quot;,&quot;credit&quot;:&quot;Gann Matsuda&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1536676480&quot;,&quot;copyright&quot;:&quot;Gann Matsuda&quot;,&quot;focal_length&quot;:&quot;150&quot;,&quot;iso&quot;:&quot;10000&quot;,&quot;shutter_speed&quot;:&quot;0.002&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_2715" data-image-description="" data-medium-file="https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg?w=300" data-large-file="https://frozenroyalty.files.wordpress.com/2019/02/dsc_2715-1.jpg?w=736" />			</div> <!-- /featured-media -->
					<div class="post-content clear">
				<a href="https://twitter.com/frozenroyalty" class="twitter-follow-button" data-button="grey" data-text-color="#581ca0" data-link-color="#13C4A5">Follow @frozenroyalty</a>
<p>EL SEGUNDO, CA &mdash; Like it or not, with the <a href="https://www.nhl.com/kings" rel="noopener noreferrer" target="_blank">Los Angeles Kings</a> having traded veteran defenseman <strong>Jake Muzzin</strong>, along with veteran forward <strong>Nate Thompson</strong> and then, defenseman <strong>Oscar Fantenberg</strong>, in recent weeks, the reality is that the Kings are officially in a rebuilding mode.</p>
<p>For the uninitiated, that means at least a few years of pain while the team acquires, primarily through the draft, young, talented players and then, develops and hones their skills in the minor leagues so that they can play in the <a href="https://www.nhl.com" rel="noopener noreferrer" target="_blank">National Hockey League</a>.</p>
<p>If their last (which was also their first) rebuild is any indication, this process could take five or six years before they might become a Stanley Cup contender again. Of course, there are no guarantees. A lot could go wrong along the way. Nevertheless, the fact that their  first rebuild resulted in them winning two Stanley Cup Championships in three seasons is a reason for hope.</p>
<p>In any case, the focus now is not so much on the current Kings team, although what they will do with their key players this summer is certainly going to be a big story. But unless a miracle happens and they become a contender within the next two or three years (can you say, &ldquo;pipe dream?&rdquo;), their current stars are not likely to be around by the time the Kings ascend to the level of Stanley Cup contender once again.</p>
<p>As such, it&rsquo;s time to start looking at the young players already in their system who could play a key role for them down the road. One such player is 22-year-old left wing <strong>Mikey Eyssimont</strong>, who was selected by the Kings in the fifth round (142nd overall) of the 2016 NHL Draft.</p>
<p>The native of Littleton, Colorado played three seasons for <a href="https://scsuhuskies.com/index.aspx?path=mhockey" rel="noopener noreferrer" target="_blank">St. Cloud State University</a> before joining the <a href="http://www.ontarioreign.com" rel="noopener noreferrer" target="_blank">Ontario Reign</a> of the <a href="http://theahl.com" rel="noopener noreferrer" target="_blank">American Hockey League</a>.</p>
<p>&ldquo;I&rsquo;m happy with my decision to leave college,&rdquo; he said. &ldquo;I think I&rsquo;ve become a better hockey player this year.&rdquo;</p>
<p>Eyssimont, who has scored seven goals and has added seven assists for 14 points in 45 games, with a &mdash;8 plus/minus rating and 35 penalty minutes, joined the Reign late last season, which helped ease him into things.</p>
<p>&ldquo;It was nice getting those three games at the end of last season, so I kind of had a full summer to know what to expect,&rdquo; he noted. &ldquo;The schedule is a lot different. There are a lot more games. But overall, I&rsquo;ve adapted well. I got used to the speed right off the bat at the start of the year.&rdquo;</p>
<p>&ldquo;Going from college, where I was a go-to guy, to coming here and trying to find my role, as a first-year pro, I&rsquo;m trying to find a different side of my game,&rdquo; he added. &ldquo;It&rsquo;s been fun. I&rsquo;m becoming a more well-rounded player because of that. That&rsquo;s part of the development path for me to make it to the next level.&rdquo;</p>
<p>&ldquo;It&rsquo;s been exciting. I&rsquo;ve learned a lot. As a team, things haven&rsquo;t gone the way we&rsquo;ve wanted, so far. Lately, things have been looking up and I&rsquo;m lucky to be on a team with some veterans who have showed me how to be a pro, on and off the ice.&rdquo;</p>
<p>But Eyssimont&rsquo;s first year in the AHL has been anything but easy. Indeed, despite his raw skill and talent, he went 15 games without scoring a goal earlier this season and is currently in the midst of a 12-game goal scoring drought.</p>
<p>&ldquo;It&rsquo;s been quite the process for Mikey,&rdquo; said Reign head coach <strong>Mike Stothers</strong>. &ldquo;I don&rsquo;t think the season has gone the way he&rsquo;s wanted. It&rsquo;s been frustrating for him. I think he&rsquo;s really fighting it. It&rsquo;s hard to play in the American Hockey league. It&rsquo;s hard to play professional hockey. It&rsquo;s hard to get ready every day, whether it&rsquo;s a practice or a game.&rdquo;</p>
<p>&ldquo;He&rsquo;s coming out of college where he was used to that routine. Now, he&rsquo;s got to get used to a new routine and ours is a little bit different from the Kings&mdash;the mode of travel&mdash;it takes a toll on you. But on the ice, I sense some frustration in him because I know he&rsquo;s looking for more results. He&rsquo;s looking for more points and they haven&rsquo;t come easy.&rdquo;</p>
<p>Often times, especially in the case of young, developing players, not getting on the score sheet often enough leads down a dead end road.</p>
<p>&ldquo;When you don&rsquo;t score, sometimes you press and try to do too much,&rdquo; Stothers explained. &ldquo;It seems like an easy thing&mdash;you haven&rsquo;t scored, so shoot the puck more. But then they try to over-handle the puck. They over-analyze things. Do I pass here? Do I shoot here? Then, it&rsquo;s over. Then there&rsquo;s nothing to show for it and another game goes by and then another.&rdquo;</p>
<p>Eyssimont indicated that he has been working hard with the Reign coaching staff and the Kings development staff.</p>
<p>&ldquo;Point production hasn&rsquo;t been there for me this year,&rdquo; he said. &ldquo;But that comes with growth, as a pro, and opportunity. That&rsquo;s something I&rsquo;m going to continue to work for.&rdquo;</p>
<p>&ldquo;As a young guy, I was given some leeway, early in the year, to see what to expect on the power play, and in different situations, and as the year has gone on, Coach Stothers has tried to be smart, and he understands that I&rsquo;m developing, as a player,&rdquo; he added. &ldquo;He knows that point production isn&rsquo;t the only sign of a player&rsquo;s development, so the coaching staff is working hard with me on video with on-ice stuff to help my point production.&rdquo;</p>
<p>&ldquo;A lot of it has been skating, but we work on fundamentals&mdash;passing and shooting to harder stuff like edges and game situations and we&rsquo;ve worked  on making space for myself and my confidence.&rdquo;</p>
<p>Stothers went into more detail regarding what they&rsquo;re focusing on with Eyssimont.</p>
<p>&ldquo;You try to create environments for him, through video, where you show him how he could have done less, as far as over-analyzing or over-handling the puck,&rdquo; he noted. &ldquo;You try to show him areas of the ice to go into where he could have better success.&rdquo;</p>
<p>&ldquo;It&rsquo;s funny,&rdquo; he added. &ldquo;Say you don&rsquo;t stop in front of the net. You just drive by. There was an opportunity that you weren&rsquo;t there for. Or maybe, instead of getting into the hole where there&rsquo;s a little bit of traffic, you&rsquo;re always on the perimeter. You&rsquo;re not going to get results.&rdquo;</p>
<p>&ldquo;You might have been able to get away with that in college or junior, but at the AHL and NHL levels, you&rsquo;ve got to penetrate into those areas and not just sometimes. You&rsquo;ve got to do it all that time, and that&rsquo;s part of the process. They realize, &lsquo;I&rsquo;m getting beaten up in here. Guys are hitting me and cross-checking me. I&rsquo;m in a battle.&rsquo; Well, do you want to stay in the battle? Or just go into the battle sometimes? If you only go into the battle sometimes, you&rsquo;re only going to get results sometimes. But it&rsquo;s coming with Mikey.&rdquo;</p>
<p>If this all sounds rather discouraging, taken at face value, you&rsquo;d be right. But under the circumstances, that sentiment is rather premature. After all, Eyssimont is a late-round draft pick and is only in his first full season at the professional level, something Stothers emphasized.</p>
<p>&ldquo;I&rsquo;m not discouraged by the lack of production,&rdquo; he said. &ldquo;I just think it&rsquo;s typical of a guy who had some success at a lower level. Again, it doesn&rsquo;t come easy up here. There&rsquo;s a price to pay to have success in the American Hockey League and in pro hockey, in general.&rdquo;</p>
<p>&ldquo;There have been a lot of guys who&rsquo;ve come out of junior hockey who had 100-point seasons,&rdquo; he added. &ldquo;Maybe they won a scoring title. But when they reach the pros, they can&rsquo;t play. It takes&lsquo;em a little bit. So we&rsquo;ll be patient with Mikey. He&rsquo;s tried hard. He needs to improve his skating, but he knows that. He needs to stay on his feet more, too. He falls down a lot and gets knocked down a lot. Maybe that&rsquo;s part of getting a stronger core, I don&rsquo;t know. Maybe it&rsquo;s part of working on his skating. But he does have a sick set of hands and you can&rsquo;t teach that. He has some legitimate offensive talent. We just haven&rsquo;t seen it yet and because he has that, you don&rsquo;t want to write him off. He just needs a little bit more time to adjust.&rdquo;</p>
<p>&ldquo;The process is there with Mikey. He&rsquo;s OK. He&rsquo;s just not where he&rsquo;d like to be, right now.&rdquo;</p>
<p><em>LEAD PHOTO: Los Angeles Kings left wing prospect Mikey Eyssimont (foreground), shown here during the 2018 rookie tournament at City National Arena in Summerlin, Nevada,  September 11, 2018. Photo: Gann Matsuda/FrozenRoyalty.net.</em></p>
<hr />
<p><a rel="license" href="http://creativecommons.org/licenses/by-nc-nd/3.0/"><img src="https://frozenroyalty.files.wordpress.com/2012/07/cc-by-3-0unported.png?w=736" alt="Creative Commons License" hspace="8" vspace="5" align="right" style="border-width:0;" /></a> <span>Frozen Royalty</span> by <a href="http://frozenroyalty.net" rel="cc:attributionURL">Gann Matsuda</a> is licensed under a <a href="http://creativecommons.org/licenses/by-nc-nd/3.0/" target="_blank" rel="license noopener noreferrer"><strong>Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License</strong></a>. You may copy, distribute and/or transmit any story or audio content published on this site under the terms of this license, but only if proper attribution is indicated. The full name of the author and a link back to the original article on this site are required. Photographs, graphic images, and other content not specified are subject to additional restrictions. Additional information is available at: <a href="https://frozenroyalty.net/copyright-licensing" target="_blank" rel="cc:morepermissions noopener noreferrer"><strong>Frozen Royalty &#8211; Licensing and Copyright Information</strong></a>.</p>
<p><strong><a href="https://frozenroyalty.net/comment-policy" target="_blank" rel="noopener noreferrer">Frozen Royalty&rsquo;s Comment Policies</a></strong></p>
		<div class="wpcnt">
			<div class="wpa wpmrec">
				<span class="wpa-about">Advertisements</span>
				<div class="u">		<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-right:5px;margin-top:0px">
		<div id="atatags-43078341-5c7a65e1396bb">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-43078341-5c7a65e1396bb',  {
					collapseEmpty: 'before',
					sectionId: '43078341',
					width: 300,
					height: 250
				});
			});
			</script>
		</div></div>		<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-top:0px">
		<div id="atatags-43078344-5c7a65e1396be">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-43078344-5c7a65e1396be',  {
					collapseEmpty: 'before',
					sectionId: '43078344',
					width: 300,
					height: 250
				});
			});
			</script>
		</div></div></div>
				
			</div>
		</div><div id="atatags-43078345-5c7a65e1396d7">
        <script type="text/javascript">
            __ATA.cmd.push(function() {
                __ATA.initVideoSlot('atatags-43078345-5c7a65e1396d7', {
                    sectionId: '43078345',
                    format: 'inread'
                });
            });
        </script>
    </div><div id="jp-post-flair" class="sharedaddy sd-rating-enabled sd-like-enabled sd-sharing-enabled"><div class="sd-block sd-rating"><h3 class="sd-title">Rate this:</h3><div class="pd-rating" id="pd_rating_holder_91224_post_56999"></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://frozenroyalty.net/2019/02/28/eyssimont-0219/" data-text="It&#039;s Been a Tough Rookie Season For LA Kings LW Prospect Mikey Eyssimont" data-via="frozenroyalty" data-related="wordpressdotcom">Tweet</a></li><li class="share-reddit"><div class="reddit_button"><iframe src="https://www.reddit.com/static/button/button1.html?newwindow=true&width=120&amp;url=https%3A%2F%2Ffrozenroyalty.net%2F2019%2F02%2F28%2Feyssimont-0219%2F&amp;title=It%27s%20Been%20a%20Tough%20Rookie%20Season%20For%20LA%20Kings%20LW%20Prospect%20Mikey%20Eyssimont" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="https://frozenroyalty.net/2019/02/28/eyssimont-0219/" data-counter="right"></script></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Ffrozenroyalty.net%2F2019%2F02%2F28%2Feyssimont-0219%2F&#038;media=https%3A%2F%2Ffrozenroyalty.files.wordpress.com%2F2019%2F02%2Fdsc_2715-1.jpg&#038;description=It%27s%20Been%20a%20Tough%20Rookie%20Season%20For%20LA%20Kings%20LW%20Prospect%20Mikey%20Eyssimont" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button" href="https://api.whatsapp.com/send?text=It%27s%20Been%20a%20Tough%20Rookie%20Season%20For%20LA%20Kings%20LW%20Prospect%20Mikey%20Eyssimont%20https%3A%2F%2Ffrozenroyalty.net%2F2019%2F02%2F28%2Feyssimont-0219%2F" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-pocket"><div class="pocket_button"><a href="https://getpocket.com/save" class="pocket-btn" data-lang="en" data-save-url="https://frozenroyalty.net/2019/02/28/eyssimont-0219/" data-pocket-count="horizontal" >Pocket</a></div></li><li class="share-skype"><div class="skype-share" data-href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/" data-lang="en-US" data-style="small" data-source="jetpack" ></div></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-tumblr"><a class="tumblr-share-button" target="_blank" href="https://www.tumblr.com/share" data-title="It's Been a Tough Rookie Season For LA Kings LW Prospect Mikey Eyssimont" data-content="https://frozenroyalty.net/2019/02/28/eyssimont-0219/" title="Share on Tumblr">Share on Tumblr</a></li><li class="share-custom share-custom-posterous"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-posterous sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=custom-1328575386" target="_blank" title="Click to share on Posterous"><span style="background-image:url(&quot;https://frozenroyalty.files.wordpress.com/2012/02/posterous.png&quot;);">Posterous</span></a></li><li class="share-custom share-custom-addthis"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-addthis sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=custom-1296125019" target="_blank" title="Click to share on AddThis"><span style="background-image:url(&quot;https://frozenroyalty.files.wordpress.com/2011/01/addthisbadge1.png&quot;);">AddThis</span></a></li><li class="share-custom share-custom-bebo"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-bebo sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=custom-1282680884" target="_blank" title="Click to share on Bebo"><span style="background-image:url(&quot;https://frozenroyalty.files.wordpress.com/2010/08/bebo-icon.png&quot;);">Bebo</span></a></li><li class="share-custom share-custom-delicious"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-delicious sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=custom-1328574766" target="_blank" title="Click to share on Delicious"><span style="background-image:url(&quot;https://frozenroyalty.files.wordpress.com/2010/08/delicious-icon.png&quot;);">Delicious</span></a></li><li class="share-custom share-custom-mixx"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-mixx sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=custom-1282680020" target="_blank" title="Click to share on Mixx"><span style="background-image:url(&quot;https://frozenroyalty.files.wordpress.com/2010/08/mixx-icon.png&quot;);">Mixx</span></a></li><li class="share-custom share-custom-newsvine"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-newsvine sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=custom-1282682503" target="_blank" title="Click to share on Newsvine"><span style="background-image:url(&quot;https://frozenroyalty.files.wordpress.com/2010/08/newsvine-icon-1.png&quot;);">Newsvine</span></a></li><li class="share-custom share-custom-share"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-share sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=custom-1313665547" target="_blank" title="Click to share on Share"><span style="background-image:url(&quot;https://frozenroyalty.files.wordpress.com/2011/08/facebook_icon.png&quot;);">Share</span></a></li><li class="share-custom share-custom-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-custom share-custom-print sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=custom-1313193850" target="_blank" title="Click to share on Print"><span style="background-image:url(&quot;https://frozenroyalty.files.wordpress.com/2011/08/icon-print-friendly-16x16.png&quot;);">Print</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://frozenroyalty.net/2019/02/28/eyssimont-0219/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>			</div><!--/.post-content-->
		
			<footer class="post-meta-container clear">
					<div class="entry-author author-avatar-show">
				<div class="author-avatar">
					</div><!-- .author-avatar -->
		
		<div class="author-heading">
			<h2 class="author-title">Published by <span class="author-name">Gann Matsuda</span></h2>
		</div><!-- .author-heading -->

		<p class="author-bio">
						<a class="author-link" href="https://frozenroyalty.net/author/frozenroyalty/" rel="author">
				View all posts by Gann Matsuda			</a>
		</p><!-- .author-bio -->
	</div><!-- .entry-auhtor -->

				<div class="post-meta clear">
					
	<time class="post-date updated" datetime="2019-02-28">
		<i class="fa fa-clock-o"></i>
		February 28, 2019	</time>

				<p class="post-categories"><i class="fa fa-folder-open"></i><a href="https://frozenroyalty.net/category/exclusives/" rel="category tag">Exclusives</a>, <a href="https://frozenroyalty.net/category/news/" rel="category tag">News</a>, <a href="https://frozenroyalty.net/category/prospects-2/" rel="category tag">Prospects</a></p>
	
	<p class="post-tags"><i class="fa fa-tag"></i><a href="https://frozenroyalty.net/tag/ahl/" rel="tag">AHL</a>, <a href="https://frozenroyalty.net/tag/american-hockey-league/" rel="tag">American Hockey League</a>, <a href="https://frozenroyalty.net/tag/mikey-eyssimont/" rel="tag">Mikey Eyssimont</a>, <a href="https://frozenroyalty.net/tag/ontario-reigh/" rel="tag">Ontario Reigh</a></p>
					
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://frozenroyalty.net/2019/02/18/matt-roy/" rel="prev">A Longer Look At LA Kings D Prospect Matt&nbsp;Roy</a></div></div>
	</nav>									</div>
			</footer> <!-- /post-meta-container -->
			


	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Please post your comment on this story below <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/02/28/eyssimont-0219/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://frozenroyalty.net/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="cfadca48ec" /><input type="hidden" name="_wp_http_referer" value="/2019/02/28/eyssimont-0219/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google+ account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='56999' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3104b0327a" /></p>
<input type="hidden" name="genseq" value="1551525345" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="210"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
	</article> <!-- /post -->


		</div> <!-- /content -->

		

	<aside class="sidebar fright" role="complementary">
				<div class="wpcnt">
			<div class="wpa wpwidesky">
				<span class="wpa-about">Advertisements</span>
				<div class="u">
							<div style="padding-bottom:15px;width:160px;height:600px;">
		<div id="atatags-43078343-5c7a65e13b6ed">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-43078343-5c7a65e13b6ed',  {
					collapseEmpty: 'before',
					sectionId: '43078343',
					width: 160,
					height: 600
				});
			});
			</script>
		</div></div>
				</div>
				
			</div>
		</div><div id="twitter_timeline-3" class="widget widget_twitter_timeline"><div class="widget-content clear"><h3 class="widget-title">Frozen Royalty on Twitter</h3><a class="twitter-timeline" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-tweet-limit="3" data-lang="EN" data-partner="jetpack" href="https://twitter.com/frozenroyalty" href="https://twitter.com/frozenroyalty">My Tweets</a></div></div><div id="wpcom_instagram_widget-3" class="widget widget_wpcom_instagram_widget"><div class="widget-content clear"><h3 class="widget-title">Frozen Royalty on Instagram</h3><div class="wpcom-instagram-images wpcom-instagram-columns-3">
<a href="https://www.instagram.com/p/BucgWaJgU4P/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/vp/ee018b4ac09fae31a4bd6a155651f292/5D1E3EAC/t51.2885-15/sh0.08/e35/s640x640/52971064_2354965837848872_5058817827135750267_n.jpg?_nc_ht=scontent.cdninstagram.com)"><span class="screen-reader-text">With the @LAKings starting a rebuilding process that could easily take five or six years, Frozen Royalty looks at prospects already in their system who could become the players who get them back to being a Stanley Cup contender.
.
One such player is left wing Mikey Eyssimont. But things aren&#039;t coming easily for him in his first season at the professional level, despite his raw offensive talent and skill. Nevertheless, there is reason for hope.
.
Read all about it by clicking on the link in our bio. Eventually, that link will expire and it&#039;ll take you to a new story. Once that happens, please type https://wp.me/pi4Fc-ePl into your browser.
.
@TheAHL #AHL #LAKings #LosAngeles @NHL #NHL @ontarioreignhockey</span></div></a>
<a href="https://www.instagram.com/p/BuBzTg6At2-/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/vp/70530131b9ed429f54f6e6e967b5625e/5D1F7CC3/t51.2885-15/sh0.08/e35/s640x640/50813749_258728628355307_6448288923989745626_n.jpg?_nc_ht=scontent.cdninstagram.com)"><span class="screen-reader-text">Young defenseman Matt Roy made his @NHL debut with the @LAKings on February 16 against the Boston Bruins and did not look out of place. Nevertheless, we don&#039;t know a whole lot about him.
.
What kind of defenseman is he? How has his development progressed? What is the outlook for him? Is he close to becoming a bona fide NHL player?
.
Read all about by clicking on the link in our bio. Eventually, that link will expire and take you to a new story. When that happens, please type https://wp.me/pi4Fc-eOI into your browser.
.
@TheAHL #AHL #hockey #LAKings #Losangeles @NHL #NHL @OntarioReignHockey</span></div></a>
<a href="https://www.instagram.com/p/Bt-yjl8gAUS/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/vp/188bc21955894486764241c83bfa2953/5D198605/t51.2885-15/sh0.08/e35/s640x640/51292057_145370059816040_3705859908308137419_n.jpg?_nc_ht=scontent.cdninstagram.com)"><span class="screen-reader-text">Fun post-game interview (almost 5 minutes!) with @LAKings emergency backup goaltender Steve Jakiel, who was one step away from making his #NHL debut vs. the Boston Bruins on February 16, 2019, at @StaplesCenterLA.
.
You can listen to the full interview here by clicking on the link in our bio. Eventually, that link will expire, taking you to a new story When that happens, please type https://wp.me/pi4Fc-eOo into your browser.
.
📸 Jeff Moeller. Courtesy Los Angeles Kings.
.
#hockey #LAKings #LosAngeles @NHL</span></div></a>
<a href="https://www.instagram.com/p/Bt3X_n2gK3S/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/vp/eef3711739809cac6e171267ef6d1638/5D076F1E/t51.2885-15/sh0.08/e35/s640x640/47690557_2180364798893440_5041312161266682464_n.jpg?_nc_ht=scontent.cdninstagram.com)"><span class="screen-reader-text">@LAKings defenseman Oscar Fantenberg scored his first two goals of the season during the team’s six-game road trip that ended on February 11. But it wasn’t just more offense from the blue line that Fantenberg provided. In fact, he was pretty solid in the defensive zone, making a solid case to be the one who takes up much of the slack left by the trade of veteran defenseman Jake Muzzin.
.
Fantenberg spoke with Frozen Royalty about his recent play and about working to stay in the lineup now that he’s beginning to turn the heads of his coaches.
.
Check it out by clicking on the link in our bio. Eventually, that link will expire and take you to a new story. Once that happens, please type  https://wp.me/pi4Fc-eOh into your browser.
.
#hockey #LAKings #LosAngeles @NHL #NHL</span></div></a>
<a href="https://www.instagram.com/p/BtqC0oNA1ci/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/vp/3cdd633b2b16b99f9c760bce3c3b00f7/5D04A083/t51.2885-15/sh0.08/e35/s640x640/50902206_101384327651473_6624020679476593079_n.jpg?_nc_ht=scontent.cdninstagram.com)"><span class="screen-reader-text">Although he has been with the @LAKings organization for less than two weeks, left wing prospect Carl Grundstrom, who came over from Toronto in the Jake Muzzin trade, is already making quite the positive impression.
.
To hear what Grundstrom thinks about his play with @OntarioReignHockey (Kings&#039; #AHL affiliate), along with what Reign head coach Mike Stothers thinks of his newest player, please click on the link in our bio. Eventually, that link will expire and will take you to a new story. When that happens, please type https://wp.me/pi4Fc-eJe into your browser.
.
@TheAHL #hockey #LAKings #LosAngeles @NHL #NHL</span></div></a>
<a href="https://www.instagram.com/p/BtX28O5g3N8/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/vp/f8e6b06c2b4809d3d9b3b8162ade94f0/5D075EF7/t51.2885-15/sh0.08/e35/s640x640/50151555_789030504780809_2323874271941785198_n.jpg?_nc_ht=scontent.cdninstagram.com)"><span class="screen-reader-text">A fast start—seven goals in a 15-game span with the @LAKings earlier this season has had both positive and negative effects on right wing prospect Matt Luff.
.
Sure, he showed that he could put the puck in the net and that he has a knack for it. But now that opposing teams are paying closer attention to him, the offense has dried up.
.
What does Luff have to do to find his scoring touch again? What does he need to do improve?
.
To hear what Luff and @OntarioReignHockey head coach Mike Stothers had to say (you&#039;ll get a chuckle out of a reference to a movie), check it out by clicking on the link in our bio. Eventually, that link will expire, taking you to a different story or post. When that happens, please type https://wp.me/pi4Fc-eJ5 into your browser.
.
@TheAHL #AHL #hockey #LAKings #LosAngeles @NHL #NHL</span></div></a>
<a href="https://www.instagram.com/p/BtLdMY6g4xf/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/vp/a887779ef03c2ecb1a7c69d40eb85fc6/5D0B27E2/t51.2885-15/sh0.08/e35/s640x640/49913298_167852510859616_1751444541578179545_n.jpg?_nc_ht=scontent.cdninstagram.com)"><span class="screen-reader-text">Rookie defenseman Sean Walker has turned a lot of heads, especially during his second stint with the @LAKings this season, displaying skill, speed, offensive ability and a right-hand shot from the blue line, which is in short supply throughout the Kings&#039; system.
.
Walker and assistant general manager Michael Futa spoke exclusively with Frozen Royalty, looking at what Walker has done to earn the attention he&#039;s been getting and more.
.
Read all about it by clicking on the link in our bio. Eventually, that link will expire and take you to a new story. Once that happens, please type https://wp.me/pi4Fc-eIR into your browser.
.
@TheAHL #AHL #hockey #LAKings #LosAngeles @NHL #NHL @ontarioreignhockey</span></div></a>
<a href="https://www.instagram.com/p/BsihsC6g90S/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/vp/255642118ec0570fd61a05b80d5707a4/5D1B11E2/t51.2885-15/sh0.08/e35/s640x640/47693948_225982875008843_7150847829310579354_n.jpg?_nc_ht=scontent.cdninstagram.com)"><span class="screen-reader-text">It’s easy to notice that @LAKings rookie left wing Austin Wagner is really, really fast, one of the fastest skaters in the @NHL. That alone makes him an offensive threat, even though he doesn&#039;t have the hands of an elite scorer.
.
There is a ton of hope and expectations among fans for Wagner, merely because he is so fast. But what&#039;s the reality about him? What are his strengths? What are the weaknesses in his game that he is working on or still needs to work on? On top of that, even though it sounds rather odd, Wagner is actually learning to slow down, at times.
.
Read what Wagner and Kings assistant general manager Michael Futa had to say about this and more by clicking on the link in our bio. Eventually, that link will expire and take you to a new story. When that happens, please type https://wp.me/pi4Fc-eIG into your browser.
.
#AHL #hockey #LAKings #LosAngeles @NHL #NHL</span></div></a>
<a href="https://www.instagram.com/p/BsHiK5DABQi/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/vp/1445e1e401d64d9a720ca4bef50b9aae/5D22E92C/t51.2885-15/sh0.08/e35/p640x640/47584533_616047898830111_5867853584658652045_n.jpg?_nc_ht=scontent.cdninstagram.com)"><span class="screen-reader-text">Daryl is going to spontaneously combust. 🤣
#LAKings

#Repost @darylevans15
・・・
Kings vs Golden Knights . Kings looking to build on a 5-1-1 record over the last 7 games. Go Kings</span></div></a>
</div>
</div></div><div id="facebook-likebox-2" class="widget widget_facebook_likebox"><div class="widget-content clear"><h3 class="widget-title"><a href="https://www.facebook.com/FrozenRoyalty">Frozen Royalty on Facebook</a></h3>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/FrozenRoyalty" data-width="340"  data-height="432" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/FrozenRoyalty"><a href="https://www.facebook.com/FrozenRoyalty">Frozen Royalty on Facebook</a></blockquote></div>
		</div>
		</div></div><div id="archives-4" class="widget widget_archive"><div class="widget-content clear"><h3 class="widget-title">Story Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-4">Story Archives</label>
		<select id="archives-dropdown-4" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://frozenroyalty.net/2019/02/'> February 2019 </option>
	<option value='https://frozenroyalty.net/2019/01/'> January 2019 </option>
	<option value='https://frozenroyalty.net/2018/12/'> December 2018 </option>
	<option value='https://frozenroyalty.net/2018/11/'> November 2018 </option>
	<option value='https://frozenroyalty.net/2018/10/'> October 2018 </option>
	<option value='https://frozenroyalty.net/2018/09/'> September 2018 </option>
	<option value='https://frozenroyalty.net/2018/07/'> July 2018 </option>
	<option value='https://frozenroyalty.net/2018/06/'> June 2018 </option>
	<option value='https://frozenroyalty.net/2018/04/'> April 2018 </option>
	<option value='https://frozenroyalty.net/2018/03/'> March 2018 </option>
	<option value='https://frozenroyalty.net/2018/02/'> February 2018 </option>
	<option value='https://frozenroyalty.net/2018/01/'> January 2018 </option>
	<option value='https://frozenroyalty.net/2017/12/'> December 2017 </option>
	<option value='https://frozenroyalty.net/2017/11/'> November 2017 </option>
	<option value='https://frozenroyalty.net/2017/10/'> October 2017 </option>
	<option value='https://frozenroyalty.net/2017/09/'> September 2017 </option>
	<option value='https://frozenroyalty.net/2017/08/'> August 2017 </option>
	<option value='https://frozenroyalty.net/2017/07/'> July 2017 </option>
	<option value='https://frozenroyalty.net/2017/06/'> June 2017 </option>
	<option value='https://frozenroyalty.net/2017/05/'> May 2017 </option>
	<option value='https://frozenroyalty.net/2017/04/'> April 2017 </option>
	<option value='https://frozenroyalty.net/2017/03/'> March 2017 </option>
	<option value='https://frozenroyalty.net/2017/02/'> February 2017 </option>
	<option value='https://frozenroyalty.net/2017/01/'> January 2017 </option>
	<option value='https://frozenroyalty.net/2016/12/'> December 2016 </option>
	<option value='https://frozenroyalty.net/2016/11/'> November 2016 </option>
	<option value='https://frozenroyalty.net/2016/10/'> October 2016 </option>
	<option value='https://frozenroyalty.net/2016/09/'> September 2016 </option>
	<option value='https://frozenroyalty.net/2016/08/'> August 2016 </option>
	<option value='https://frozenroyalty.net/2016/07/'> July 2016 </option>
	<option value='https://frozenroyalty.net/2016/06/'> June 2016 </option>
	<option value='https://frozenroyalty.net/2016/05/'> May 2016 </option>
	<option value='https://frozenroyalty.net/2016/04/'> April 2016 </option>
	<option value='https://frozenroyalty.net/2016/03/'> March 2016 </option>
	<option value='https://frozenroyalty.net/2016/02/'> February 2016 </option>
	<option value='https://frozenroyalty.net/2016/01/'> January 2016 </option>
	<option value='https://frozenroyalty.net/2015/12/'> December 2015 </option>
	<option value='https://frozenroyalty.net/2015/11/'> November 2015 </option>
	<option value='https://frozenroyalty.net/2015/10/'> October 2015 </option>
	<option value='https://frozenroyalty.net/2015/09/'> September 2015 </option>
	<option value='https://frozenroyalty.net/2015/08/'> August 2015 </option>
	<option value='https://frozenroyalty.net/2015/07/'> July 2015 </option>
	<option value='https://frozenroyalty.net/2015/06/'> June 2015 </option>
	<option value='https://frozenroyalty.net/2015/05/'> May 2015 </option>
	<option value='https://frozenroyalty.net/2015/04/'> April 2015 </option>
	<option value='https://frozenroyalty.net/2015/03/'> March 2015 </option>
	<option value='https://frozenroyalty.net/2015/02/'> February 2015 </option>
	<option value='https://frozenroyalty.net/2015/01/'> January 2015 </option>
	<option value='https://frozenroyalty.net/2014/12/'> December 2014 </option>
	<option value='https://frozenroyalty.net/2014/11/'> November 2014 </option>
	<option value='https://frozenroyalty.net/2014/10/'> October 2014 </option>
	<option value='https://frozenroyalty.net/2014/09/'> September 2014 </option>
	<option value='https://frozenroyalty.net/2014/08/'> August 2014 </option>
	<option value='https://frozenroyalty.net/2014/07/'> July 2014 </option>
	<option value='https://frozenroyalty.net/2014/06/'> June 2014 </option>
	<option value='https://frozenroyalty.net/2014/05/'> May 2014 </option>
	<option value='https://frozenroyalty.net/2014/04/'> April 2014 </option>
	<option value='https://frozenroyalty.net/2014/03/'> March 2014 </option>
	<option value='https://frozenroyalty.net/2014/02/'> February 2014 </option>
	<option value='https://frozenroyalty.net/2014/01/'> January 2014 </option>
	<option value='https://frozenroyalty.net/2013/12/'> December 2013 </option>
	<option value='https://frozenroyalty.net/2013/11/'> November 2013 </option>
	<option value='https://frozenroyalty.net/2013/10/'> October 2013 </option>
	<option value='https://frozenroyalty.net/2013/09/'> September 2013 </option>
	<option value='https://frozenroyalty.net/2013/08/'> August 2013 </option>
	<option value='https://frozenroyalty.net/2013/07/'> July 2013 </option>
	<option value='https://frozenroyalty.net/2013/06/'> June 2013 </option>
	<option value='https://frozenroyalty.net/2013/05/'> May 2013 </option>
	<option value='https://frozenroyalty.net/2013/04/'> April 2013 </option>
	<option value='https://frozenroyalty.net/2013/03/'> March 2013 </option>
	<option value='https://frozenroyalty.net/2013/02/'> February 2013 </option>
	<option value='https://frozenroyalty.net/2013/01/'> January 2013 </option>
	<option value='https://frozenroyalty.net/2012/12/'> December 2012 </option>
	<option value='https://frozenroyalty.net/2012/11/'> November 2012 </option>
	<option value='https://frozenroyalty.net/2012/10/'> October 2012 </option>
	<option value='https://frozenroyalty.net/2012/09/'> September 2012 </option>
	<option value='https://frozenroyalty.net/2012/08/'> August 2012 </option>
	<option value='https://frozenroyalty.net/2012/07/'> July 2012 </option>
	<option value='https://frozenroyalty.net/2012/06/'> June 2012 </option>
	<option value='https://frozenroyalty.net/2012/05/'> May 2012 </option>
	<option value='https://frozenroyalty.net/2012/04/'> April 2012 </option>
	<option value='https://frozenroyalty.net/2012/03/'> March 2012 </option>
	<option value='https://frozenroyalty.net/2012/02/'> February 2012 </option>
	<option value='https://frozenroyalty.net/2012/01/'> January 2012 </option>
	<option value='https://frozenroyalty.net/2011/12/'> December 2011 </option>
	<option value='https://frozenroyalty.net/2011/11/'> November 2011 </option>
	<option value='https://frozenroyalty.net/2011/10/'> October 2011 </option>
	<option value='https://frozenroyalty.net/2011/09/'> September 2011 </option>
	<option value='https://frozenroyalty.net/2011/08/'> August 2011 </option>
	<option value='https://frozenroyalty.net/2011/07/'> July 2011 </option>
	<option value='https://frozenroyalty.net/2011/06/'> June 2011 </option>
	<option value='https://frozenroyalty.net/2011/05/'> May 2011 </option>
	<option value='https://frozenroyalty.net/2011/04/'> April 2011 </option>
	<option value='https://frozenroyalty.net/2011/03/'> March 2011 </option>
	<option value='https://frozenroyalty.net/2011/02/'> February 2011 </option>
	<option value='https://frozenroyalty.net/2011/01/'> January 2011 </option>
	<option value='https://frozenroyalty.net/2010/12/'> December 2010 </option>
	<option value='https://frozenroyalty.net/2010/11/'> November 2010 </option>
	<option value='https://frozenroyalty.net/2010/10/'> October 2010 </option>
	<option value='https://frozenroyalty.net/2010/09/'> September 2010 </option>
	<option value='https://frozenroyalty.net/2010/08/'> August 2010 </option>
	<option value='https://frozenroyalty.net/2010/07/'> July 2010 </option>
	<option value='https://frozenroyalty.net/2010/06/'> June 2010 </option>
	<option value='https://frozenroyalty.net/2010/05/'> May 2010 </option>
	<option value='https://frozenroyalty.net/2010/04/'> April 2010 </option>
	<option value='https://frozenroyalty.net/2010/03/'> March 2010 </option>
	<option value='https://frozenroyalty.net/2010/02/'> February 2010 </option>
	<option value='https://frozenroyalty.net/2010/01/'> January 2010 </option>
	<option value='https://frozenroyalty.net/2009/12/'> December 2009 </option>
	<option value='https://frozenroyalty.net/2009/11/'> November 2009 </option>
	<option value='https://frozenroyalty.net/2009/10/'> October 2009 </option>
	<option value='https://frozenroyalty.net/2009/09/'> September 2009 </option>
	<option value='https://frozenroyalty.net/2009/08/'> August 2009 </option>
	<option value='https://frozenroyalty.net/2009/07/'> July 2009 </option>
	<option value='https://frozenroyalty.net/2009/06/'> June 2009 </option>
	<option value='https://frozenroyalty.net/2009/05/'> May 2009 </option>
	<option value='https://frozenroyalty.net/2009/04/'> April 2009 </option>
	<option value='https://frozenroyalty.net/2009/03/'> March 2009 </option>
	<option value='https://frozenroyalty.net/2009/02/'> February 2009 </option>
	<option value='https://frozenroyalty.net/2009/01/'> January 2009 </option>
	<option value='https://frozenroyalty.net/2008/12/'> December 2008 </option>
	<option value='https://frozenroyalty.net/2008/11/'> November 2008 </option>
	<option value='https://frozenroyalty.net/2008/10/'> October 2008 </option>
	<option value='https://frozenroyalty.net/2008/09/'> September 2008 </option>
	<option value='https://frozenroyalty.net/2008/08/'> August 2008 </option>
	<option value='https://frozenroyalty.net/2008/07/'> July 2008 </option>
	<option value='https://frozenroyalty.net/2008/06/'> June 2008 </option>
	<option value='https://frozenroyalty.net/2008/05/'> May 2008 </option>
	<option value='https://frozenroyalty.net/2008/04/'> April 2008 </option>
	<option value='https://frozenroyalty.net/2008/03/'> March 2008 </option>
	<option value='https://frozenroyalty.net/2008/02/'> February 2008 </option>
	<option value='https://frozenroyalty.net/2008/01/'> January 2008 </option>
	<option value='https://frozenroyalty.net/2007/12/'> December 2007 </option>
	<option value='https://frozenroyalty.net/2007/11/'> November 2007 </option>
	<option value='https://frozenroyalty.net/2007/10/'> October 2007 </option>
	<option value='https://frozenroyalty.net/2007/09/'> September 2007 </option>
	<option value='https://frozenroyalty.net/2007/07/'> July 2007 </option>
	<option value='https://frozenroyalty.net/2007/05/'> May 2007 </option>
	<option value='https://frozenroyalty.net/2007/02/'> February 2007 </option>

		</select>
		</div></div><div id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget"><div class="widget-content clear"><h3 class="widget-title"><label for="subscribe-field">Subscribe to Frozen Royalty via e-mail!</label></h3>
            <form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8"
                  id="subscribe-blog">
									<p>Enter your e-mail address to follow this blog and receive notifications of new posts by email.</p>
                    <p><input type="text" name="email" style="width: 95%; padding: 1px 2px"
                              placeholder="Enter your email address" value=""
                              id="subscribe-field"/></p>
				
                <p>
                    <input type="hidden" name="action" value="subscribe"/>
                    <input type="hidden" name="blog_id" value="4307834"/>
                    <input type="hidden" name="source" value="https://frozenroyalty.net/2019/02/28/eyssimont-0219/"/>
                    <input type="hidden" name="sub-type" value="widget"/>
                    <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/>
					<input type="hidden" id="_wpnonce" name="_wpnonce" value="93078f6c57" />                    <button type="submit"
		                		                                    >
		                Sign me up!                    </button>
                </p>
            </form>
			
</div></div><div id="google_translate_widget-2" class="widget widget_google_translate_widget"><div class="widget-content clear"><h3 class="widget-title">Translate Frozen Royalty</h3><div id="google_translate_element"></div></div></div>		<div class="wpcnt">
			<div class="wpa wpwidesky">
				<span class="wpa-about">Advertisements</span>
				<div class="u">
							<div style="padding-bottom:15px;width:160px;height:600px;">
		<div id="atatags-43078343-5c7a65e13db30">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-43078343-5c7a65e13db30',  {
					collapseEmpty: 'before',
					sectionId: '43078343',
					width: 160,
					height: 600
				});
			});
			</script>
		</div></div>
				</div>
				
			</div>
		</div>	</aside><!-- /sidebar -->


	</main> <!-- /section-inner -->
</div> <!-- /wrapper -->


	<div class="footer bg-graphite" id="footer">
		<div class="section-inner row clear" role="complementary">

			
				<div class="column column-1 one-third medium-padding">
					<div class="widgets">
						<div id="media_image-3" class="widget widget_media_image"><div class="widget-content clear"><h3 class="widget-title">Gann Matsuda is a member of the&#8230;</h3><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><img width="211" height="204" src="https://frozenroyalty.files.wordpress.com/2013/01/phwa.png?w=211" class="image wp-image-23508 aligncenter attachment-214x204 size-214x204" alt="" style="max-width: 100%; height: auto;" srcset="https://frozenroyalty.files.wordpress.com/2013/01/phwa.png?w=211 211w, https://frozenroyalty.files.wordpress.com/2013/01/phwa.png?w=150 150w, https://frozenroyalty.files.wordpress.com/2013/01/phwa.png?w=300 300w, https://frozenroyalty.files.wordpress.com/2013/01/phwa.png 317w" sizes="(max-width: 211px) 100vw, 211px" data-attachment-id="23508" data-permalink="https://frozenroyalty.net/phwa/" data-orig-file="https://frozenroyalty.files.wordpress.com/2013/01/phwa.png" data-orig-size="317,306" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="PHWA" data-image-description="" data-medium-file="https://frozenroyalty.files.wordpress.com/2013/01/phwa.png?w=300" data-large-file="https://frozenroyalty.files.wordpress.com/2013/01/phwa.png?w=317" /></div></div>					</div>
				</div>

			 <!-- /sidebar-2 -->

			
				<div class="column column-2 one-third medium-padding">
					<div class="widgets">
						<div id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-content clear"><div class="textwidget custom-html-widget"><p><strong>The Frozen Royalty logo was designed by Richard Garcia. © 2010, 2012 Gann Matsuda/FrozenRoyalty.net. All rights reserved. Duplication is prohibited without explicit permission.</strong></p>
<p>The logos of the <a href="https://www.nhl.com/kings" rel="noopener" target="_blank">Los Angeles Kings</a>, the 30 other <a href="https://www.nhl.com" rel="noopener" target="_blank">National Hockey League</a> teams, and of the NHL, are trademarks of their respective rightsholders and are used with permission of the NHL and its teams.</p></div></div></div>					</div> <!-- /widgets -->
				</div>

			 <!-- /sidebar-3 -->

			
				<div class="column column-3 one-third medium-padding">
					<div class="widgets">
						<div id="pages-2" class="widget widget_pages"><div class="widget-content clear"><h3 class="widget-title">Guide To Attending LA Kings Practices</h3>		<ul>
			<li class="page_item page-item-41210"><a href="https://frozenroyalty.net/attending-los-angeles-kings-practice-sessions/">Attending Los Angeles Kings Practice&nbsp;Sessions</a></li>
		</ul>
			</div></div>					</div> <!-- /widgets -->
				</div>

			 <!-- /sidebar-4 -->

		</div> <!-- /section-inner -->
	</div> <!-- /footer -->


	<div class="credits section bg-dark small-padding">
		<div class="credits-inner section-inner clear">

			<p class="credits-left fleft">
				<a href="https://wordpress.com/?ref=footer_custom_svg" title="Create a website or blog at WordPress.com"><svg style="fill: currentColor; position: relative; top: 1px;" width="14px" height="15px" viewBox="0 0 14 15" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" aria-labelledby="title" role="img">
				<desc id="title">Create a website or blog at WordPress.com</desc>
				<path d="M12.5225848,4.97949746 C13.0138466,5.87586309 13.2934037,6.90452431 13.2934037,7.99874074 C13.2934037,10.3205803 12.0351007,12.3476807 10.1640538,13.4385638 L12.0862862,7.88081544 C12.4453251,6.98296834 12.5648813,6.26504621 12.5648813,5.62667922 C12.5648813,5.39497674 12.549622,5.17994084 12.5225848,4.97949746 L12.5225848,4.97949746 Z M7.86730089,5.04801561 C8.24619178,5.02808979 8.58760099,4.98823815 8.58760099,4.98823815 C8.9267139,4.94809022 8.88671369,4.44972248 8.54745263,4.46957423 C8.54745263,4.46957423 7.52803983,4.54957381 6.86996227,4.54957381 C6.25158863,4.54957381 5.21247202,4.46957423 5.21247202,4.46957423 C4.87306282,4.44972248 4.83328483,4.96816418 5.17254589,4.98823815 C5.17254589,4.98823815 5.49358462,5.02808979 5.83269753,5.04801561 L6.81314716,7.73459399 L5.43565839,11.8651647 L3.14394256,5.04801561 C3.52312975,5.02808979 3.86416859,4.98823815 3.86416859,4.98823815 C4.20305928,4.94809022 4.16305906,4.44972248 3.82394616,4.46957423 C3.82394616,4.46957423 2.80475558,4.54957381 2.14660395,4.54957381 C2.02852925,4.54957381 1.88934333,4.54668493 1.74156477,4.54194422 C2.86690406,2.83350881 4.80113651,1.70529256 6.99996296,1.70529256 C8.638342,1.70529256 10.1302017,2.33173369 11.2498373,3.35765419 C11.222726,3.35602457 11.1962815,3.35261718 11.1683554,3.35261718 C10.5501299,3.35261718 10.1114609,3.89113285 10.1114609,4.46957423 C10.1114609,4.98823815 10.4107217,5.42705065 10.7296864,5.94564049 C10.969021,6.36482346 11.248578,6.90326506 11.248578,7.68133501 C11.248578,8.21992476 11.0413918,8.84503256 10.7696866,9.71584277 L10.1417574,11.8132391 L7.86730089,5.04801561 Z M6.99996296,14.2927074 C6.38218192,14.2927074 5.78595654,14.2021153 5.22195356,14.0362644 L7.11048207,8.54925635 L9.04486267,13.8491542 C9.05760348,13.8802652 9.07323319,13.9089317 9.08989995,13.9358945 C8.43574834,14.1661896 7.73285573,14.2927074 6.99996296,14.2927074 L6.99996296,14.2927074 Z M0.706448182,7.99874074 C0.706448182,7.08630113 0.902152921,6.22015756 1.25141403,5.43749503 L4.25357806,13.6627848 C2.15393732,12.6427902 0.706448182,10.4898387 0.706448182,7.99874074 L0.706448182,7.99874074 Z M6.99996296,0.999 C3.14016476,0.999 0,4.13905746 0,7.99874074 C0,11.8585722 3.14016476,14.999 6.99996296,14.999 C10.8596871,14.999 14,11.8585722 14,7.99874074 C14,4.13905746 10.8596871,0.999 6.99996296,0.999 L6.99996296,0.999 Z" id="wordpress-logo-simplified-cmyk" stroke="none" fill=“currentColor” fill-rule="evenodd"></path>
			</svg></a>
				
							</p>

			<p class="credits-right fright">
				<a class="tothetop" title="To the top" href="#">Up &uarr;</a>
			</p>
		</div> <!-- /credits-inner -->
	</div> <!-- /credits -->

<!--  -->
	<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/frozenroyalty.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/frozenroyalty.wordpress.com\/wp-login.php?action=logout&_wpnonce=c7c285dc4c","homeURL":"https:\/\/frozenroyalty.net\/","postID":"56999","gravDefault":"blank","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1550785955j'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=20111117'></script>
<script type='text/javascript' charset='UTF-8' id='polldaddyRatings'><!--//--><![CDATA[//><!--
PDRTJS_settings_91224_post_56999={"id":91224,"unique_id":"wp-post-56999","title":"It%26%238217%3Bs%20Been%20a%20Tough%20Rookie%20Season%20For%20LA%20Kings%20LW%20Prospect%20Mikey%26nbsp%3BEyssimont","permalink":"https:\/\/frozenroyalty.net\/2019\/02\/28\/eyssimont-0219\/","item_id":"_post_56999"}; if ( typeof PDRTJS_RATING !== 'undefined' ){if ( typeof PDRTJS_91224_post_56999 == 'undefined' ){PDRTJS_91224_post_56999 = new PDRTJS_RATING( PDRTJS_settings_91224_post_56999 );}}
//--><!]]></script><script type='text/javascript' charset='UTF-8' src='https://polldaddy.com/js/rating/rating.js'></script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/frozenroyalty.net\/2019\/02\/28\/eyssimont-0219\/":56999};
	</script>
				<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
				<script>
		// Don't use Pocket's default JS as it we need to force init new Pocket share buttons loaded via JS.
		function jetpack_sharing_pocket_init() {
			jQuery.getScript( 'https://widgets.getpocket.com/v1/j/btn.js?v=1' );
		}
		jQuery( document ).ready( jetpack_sharing_pocket_init );
		jQuery( document.body ).on( 'post-load', jetpack_sharing_pocket_init );
		</script>
					<script>
				(function(r, d, s) {
					r.loadSkypeWebSdkAsync = r.loadSkypeWebSdkAsync || function(p) {
							var js, sjs = d.getElementsByTagName(s)[0];
							if (d.getElementById(p.id)) { return; }
							js = d.createElement(s);
							js.id = p.id;
							js.src = p.scriptToLoad;
							js.onload = p.callback
							sjs.parentNode.insertBefore(js, sjs);
						};
					var p = {
						scriptToLoad: 'https://swx.cdn.skype.com/shared/v/latest/skypewebsdk.js',
						id: 'skype_web_sdk'
					};
					r.loadSkypeWebSdkAsync(p);
				})(window, document, 'script');
			</script>
			<script id="tumblr-js" type="text/javascript" src="https://assets.tumblr.com/share-button.js"></script>	<div id="sharing_email" style="display: none;">
		<form action="/2019/02/28/eyssimont-0219/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"></div>
			<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en" async></script>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"4307834","siteName":"frozenroyalty.net","siteURL":"https:\/\/frozenroyalty.net","icon":"<img alt='' src='https:\/\/s2.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/baskerville-2","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/frozenroyalty.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Ffrozenroyalty.net%2F2019%2F02%2F28%2Feyssimont-0219%2F","themeURL":"https:\/\/wordpress.com\/theme\/baskerville-2\/","xhrURL":"https:\/\/frozenroyalty.net\/wp-admin\/admin-ajax.php","nonce":"f28df44473","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"93078f6c57\" \/>","referer":"https:\/\/frozenroyalty.net\/2019\/02\/28\/eyssimont-0219\/","canFollow":"1","feedID":"56642292","statusMessage":"","customizeLink":"https:\/\/frozenroyalty.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Ffrozenroyalty.wordpress.com%2F2019%2F02%2F28%2Feyssimont-0219%2F","postID":"56999","shortlink":"https:\/\/wp.me\/pi4Fc-ePl","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/frozenroyalty.net\/56999","statsLink":"https:\/\/wordpress.com\/stats\/post\/56999\/frozenroyalty.net","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Baskerville 2","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 188 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/frozenroyalty.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Ffrozenroyalty.net%2F2019%2F02%2F28%2Feyssimont-0219%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wp_google_translate_widget = {"lang":"en","layout":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVUe1uwjAMfKGFABs/pz3KlCZucet8LHYoe/u50sQQoIr9s+y7s31n52J8TgJJ7Mg2wAk9lPNm5Bd7NYrNFGoDJraEE7D9atDg6FIgqLdgOUJUSGmd7RxPUE9IBGa/LOAJiyFMk+mzb2x6vNu1Ru8JzkwY/pZi8tSC4nWK0Q3AlF2AsImYHmGi45zq9/X4mcUD5c7RI0GfY1S2qVDooeyVdzOGAYQtNJ3mCcGQm61ALOQEbvorOiNIcX6yn3qI7Z2HTlkGYqd/P8mSGUWgGsEImges8FzQr0zn6mKecrQy+QS14mLBpfdPBal6C6+RvGBOC+lSraEn5AhiXjfbX1tyjU9EMeQ8aMh6TeIlhLuGanzE993hsD3s9rvt2/gDNaAxkA=='></script>
<script type='text/javascript' src='//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit&#038;ver=5.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/post-flair/sharing/sharing.js?m=1522660387h'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?59" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'4307834','blog_tz':'-8','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'4307834','v':'wpcom','tz':'-8','user_id':'0','post':'56999','subd':'frozenroyalty'}]);
_stq.push(['extra', {'crypt':'UE5tW3cvZGRQTEdzcVBULHR1ck02P1RUUVhCJnJpRnpUNiYrXTYuPSVuY1VRVUZ2TnY/MWhwb2RnZ3QwRS95dHdsZFNVZS5VazJNJUZRazIvdH4uRVoxLz1IQXwlcU1rdFFnNWVDb1lOXyZOOGR3NDNITURLNE9kQ1BbV24sLit1ZUlPVS9YOS5tT3FbNSZEY015LzFZYUF3dC18V2p+dlA2Z1Q1JVNUJixlQmRQNF1dSFhUdEZbeGMsQXx2TTFbVV1yNSYyT3xCbENQcE81Xzk2ZiwlUGlCX25JYUxOamZlTGZkZHpyUVtzbEJ8WEw2NUgxT09XdU0mUG5yPUdBP2JfeHFUV3lpW35zV0RvLXk1SWExeSxZc2E0Y0JqVHJ1QVVdNGprNWNNJVFkfltTekpyW3A='}]);
_stq.push([ 'clickTrackerInit', '4307834', '56999' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
